Author Topic: Security Issue in Paradox Games (modding)  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

Offline steve58

  • Condottieri
  • ******
  • Posts: 3487
Security Issue in Paradox Games (modding)
« on: February 07, 2020, 06:46:10 AM »
Just a heads up that a security issue has been found in how LUA libraries are loaded for mods in several Paradox games.  Games affected are CKII, EUIV, HOI IV, and maybe others.  A Hotfix is already out for CKII.   

https://forum.paradoxplaza.com/forum/index.php?threads/ck2-hotfix-3-3-2-checksum-iivc-update-feb-7.1317639/

https://www.reddit.com/r/paradoxplaza/comments/ezqwel/security_flaw_in_hearts_of_iron_iv/
The democracy will cease to exist when you take away from those who are willing to work and give to those who would not.   Thomas Jefferson

During times of universal deceit, telling the truth becomes a revolutionary act.   George Orwell

If you ever find yourself in need of a safe space then you’re probably going to have to stop calling yourself a social justice warrior. You cannot be a warrior and a pansy at the same time.   Mike Adams

Offline Rayfer

  • Condottieri
  • ******
  • Posts: 2461
Re: Security Issue in Paradox Games (modding)
« Reply #1 on: February 07, 2020, 07:50:22 AM »
Saw this too and immediately uninstalled all Paradox games, all of which had one mod or another.  Am I overreacting? 

Offline W8taminute

  • Landsknecht
  • *******
  • Posts: 4484
  • Aboard the Praetor's Pride
Re: Security Issue in Paradox Games (modding)
« Reply #2 on: February 07, 2020, 12:16:26 PM »
Saw this too and immediately uninstalled all Paradox games, all of which had one mod or another.  Am I overreacting?

No you're not overacting IMHO.  I would have done the same thing except I uninstalled all my Paradox games a while ago due to abject boredom with their games formulae.
Forgive me my old friend.  But I must use all my experience...to get home.

Offline 88mmkwk

  • Hoplite
  • *
  • Posts: 15
Re: Security Issue in Paradox Games (modding)
« Reply #3 on: February 08, 2020, 09:56:59 AM »
Just fired up my Steam-hosted EU4 and saw that the 1.29.5 security patch released yesterday for the issue has been applied to my install.  Whatever else anyone thinks about Steam, their auto-update in scenarios like this is something I love.... :smitten:
Gaming Rig:
HP Spectre x360 Convertible Laptop w/Pen Support
Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz w/16GB RAM
HP Omen Thunderbolt 3 External GPU/Storage Chassis with NVIDIA GeForce GTX 1070 Ti and 1GB SSD