History, Reference, Research, and GrogTalk > References and Research

Osprey Website??

<< < (2/2)

Grim.Reaper:
For those having issues with Osprey, possibly solution for you. Seems they are having trouble with the wrong country being assigned to people as their store. For example, by default I was put in United Kingdom store and I didnít realize that, then I added all my free books and attempted to checkout. Then received message said I had incorrect store because of my address not matching United Kingdom. I tried changing the country (at top of screen) and continue to lock up and even when I tried login, would often time out. I figured out the issue was because of the incorrect store and the items in my cart being selected when I had the incorrect country set.

To fix it:

1) Login to the site while the incorrect country is set (in my case United Kingdom)Öthis will allow you to login. The country dropdown at top of the screen must be set to the incorrect country that was set when you first added your books to the cart.

2) Go to your shopping cart, remove all the contents you added when you had the incorrect country selected.

3) Now go to the top of the screen and change the country to the correct one (in my case United States)

4) Then go and re-add all the free books again.

5) Then go through the checkout process and it will work fine.

It appears there is some issue between the country it selects for you and the items in your cart being linked to that. Following the steps above, worked great for me and instantly was able to get my books after struggling the last few days.

Hope this helps people who might be experiencing the same problem.
Modify message

WallysWorld:
Thanks for posting that, Grim.Reaper. I followed your instructions and managed to get week 3's and week 4's books downloaded.

W8taminute:
Thanks Grim.  Those instructions helped me resolve my log in issues.

Navigation

[0] Message Index

[*] Previous page

Go to full version